Wednesday, January 19, 2011

Good AIX commands to refer


The Top Six

There are the most used performance commands on AIX are:
Name
Comments
vmstat
Run queue, virtual memory statistics, paging, CPU Utilization and more
iostat
Disk and adapters statistics and CPU Utilization
netstat
Network statistics (obviously) but hard to use to monitor
topas
Excellent online screen and a good summary of everything you need
ps
Process list with lots of options and details
???
What would be your choice for the next tool?

General AIX Performance Tools by Resource

The following AIX performance tools provide general information and metrics related to performance.
Resource
Command
CPU Monitoring
vmstat, iostat, topas, sar, time/timex
Memory Montiroing
vmstat, topas, ps, lsps, ipcs
I/O Subsystem
vmstat, topas, iostat, lvmstat, lsps, lsatt/lsdev, lspv/lsvg/lslv
Network
netstat, topas, atmstat, entstat, tokstat, fddistat, nfsstat, ifconfig
Processes & Threads
ps, pstat, topas

In Depth Tools

The following AIX performance tools provide in-depth information and metrics related to performance.
Resource
Command
CPU Monitoring
netpmon
Memory Montiroing
svmon, netpmon, and filemon
I/O Subsystem
filemon, fileplace
Network
netpmon, tcpdump
Processes & Threads
svmon, truss,kdb, dbx, gprof, fuser, prof

Trace based commands

An Event Based Trace Facility collects information about events that occur on the system such as scheduling dispatches, interrupts, and I/O. Trace points are inserted in the kernel code to record the events to a trace buffer. User level tools are provided to view the trace events in a time sequenced fashion. The events can be analyzed to gain a better understanding of the dynamics of the system.
Resource
Command
CPU Monitoring
tprof, curt, splat, trace, trcrpt
Memory Montiroing
trace, trcrpt
I/O Subsystem
trace, trcrpt
Network
iptrace, ipreport, trace, trcrpt
Processes & Threads
tprof, pprof, trace, trcrpt

NEW AIX Performance Commands for Micro Partitions

Name
Comments
mpstat
Collects and displays performance statistics for all logical CPUs in the system
lparstat
Reports logical partition (LPAR) related information and statistics